Excel - ÇOKETOPLA Formülü Kullanımı


28.04.2021 / Serdar Kardan


Excel - ÇOKETOPLA Formülü Kullanımı

Birden çok koşula göre değerleri toplamak için ÇOKETOPLA formülünü kullanabiliriz

Elimizde aşağıdaki tabloda görülen gibi bir veri olduğunu düşünelim. Bu veriden farklı analizler çıkarmamız gerekebilir.

Excel ÇOKETOPLA Formülü - Örnek Excel Tablosu

Örneğin belli bir coğrafi bölgedeki ya da ildeki satışların toplamlarını bulmamız gerekebilir. Belki de ürün grubu bazında bir toplama ihtiyacımız olacak. 

Bunu yapmak elbette pivot tablo ile mümkün ancak bir rapor içerisinde tek bir alan olarak görüntülememiz gereken bir durum olursa bunu da örnekteki formüllerle yapmamız mümkün...

Tablodaki örnek kayıtları baz alarak örneğin Marmara Bölgesi toplam satışlarını bulmak istersek formülümüz şu şekilde olacak;

=ÇOKETOPLA(E2:E26;A2:A26;"Marmara")

Bu formülün açılımını şöyle açıklayabiliriz;

=ÇOKETOPLA başlangıcından sonra ilk alanda E2:E26 ile işaretlenen alan tutar bilgisinin olduğu alan yani buradaki değerler toplanacak. A2:A26 ile işaretlenen alan ise vereceğimiz anahtar kelimenin aranacağı alanı gösteriyor. "Marmara" şeklinde verilen parametre ise bizim anahtar kelimemiz.

Sonuç ise şu şekilde çıkıyor;

Marmara - Toplam Satışlar     ₺26.600 

Örneğin Erzurum ilindeki satışların toplamını bulmamız gerekirse de formülü aramanın yapılacağı sütun olarak Şehir bilgisi içeren B sütununu işaret edecek şekilde değiştiriyoruz.

=ÇOKETOPLA(E2:E26;B2:B26;"Erzurum")

Bir adım daha ileri giderek formülü bir daha karmaşık hale getirelim. Karadeniz bölgesinde bulunan Emin Market' in Sebze satışlarının toplamını bulmak istiyorsak da formülü aşağıdaki şekilde kullanacağız;

=ÇOKETOPLA(E2:E26;A2:A26;"Karadeniz";C2:C26;"Emin Market";D2:D26;"Sebze")

Anlaşılacağı gibi A2:A26 ile ilk parametrenin aranacağı sütunu ve peşinden anahtar kelimeyi, C2:C26 ile ikinci arama sütununu ve peşinden o alanda aranacak anahtar kelimeyi ve D2:D26 ile de üçüncü parametreyi belirtmiş oluyoruz.

Yukarıdaki formüllerin sonuçları da şu şekilde görüntülenebilir;

Excel ÇOKETOPLA formülü - Formül Sonuçları

Bu örneklerden yola çıkarak daha karmaşık tablolarda istediğimiz kadar derinleştirebileceğimiz toplamlar bulmamız mümkün.
 



28.04.2021 - 1292


Etiketler : excel,çoketopla formülü,Birden çok koşula dayalı olarak değerleri toplama,excel toplama işlemi,pivot
Leave a Comment:

Bunlar da ilginizi çekebilir
Microsoft Dijital KOBİ Zirvesi
26 Eylül Cuma gerçekleşecek olan Dijital Kobi Zirvesine hemen kayıt olun
Login Sistemi ve Session Kullanımı
Bu derste, web sitenizde kullanabileceğiniz ve temel olarak bir login sisteminde ihtiyaç duyacağınız, güvenlik önlemleriyle birlikte bir kod örneğini inceleyeceğiz ve veritabanında kayıtlı kullanıcı adlarını kontrol ederek giriş yapmayı öğreneceğiz.
SQL - 1
SQL, (Structured Query Language - Yapılırılmış Sorgu Dili) verileri yönetmek ve tasarlamak için kullanılan bir veritabanı yönetim sistemidir.
 

En çok Okunanlar



Bumerang - Yazarkafe