AdminGuide
BETA

Excel - ÇOKETOPLA Formülü Kullanımı

Excel - ÇOKETOPLA Formülü Kullanımı

Birden çok koşula göre değerleri toplamak için ÇOKETOPLA formülünü kullanabiliriz

Elimizde aşağıdaki tabloda görülen gibi bir veri olduğunu düşünelim. Bu veriden farklı analizler çıkarmamız gerekebilir.

Excel ÇOKETOPLA Formülü - Örnek Excel Tablosu

Örneğin belli bir coğrafi bölgedeki ya da ildeki satışların toplamlarını bulmamız gerekebilir. Belki de ürün grubu bazında bir toplama ihtiyacımız olacak. 

Bunu yapmak elbette pivot tablo ile mümkün ancak bir rapor içerisinde tek bir alan olarak görüntülememiz gereken bir durum olursa bunu da örnekteki formüllerle yapmamız mümkün...

Tablodaki örnek kayıtları baz alarak örneğin Marmara Bölgesi toplam satışlarını bulmak istersek formülümüz şu şekilde olacak;

=ÇOKETOPLA(E2:E26;A2:A26;"Marmara")

Bu formülün açılımını şöyle açıklayabiliriz;

=ÇOKETOPLA başlangıcından sonra ilk alanda E2:E26 ile işaretlenen alan tutar bilgisinin olduğu alan yani buradaki değerler toplanacak. A2:A26 ile işaretlenen alan ise vereceğimiz anahtar kelimenin aranacağı alanı gösteriyor. "Marmara" şeklinde verilen parametre ise bizim anahtar kelimemiz.

Sonuç ise şu şekilde çıkıyor;

Marmara - Toplam Satışlar     ₺26.600 

Örneğin Erzurum ilindeki satışların toplamını bulmamız gerekirse de formülü aramanın yapılacağı sütun olarak Şehir bilgisi içeren B sütununu işaret edecek şekilde değiştiriyoruz.

=ÇOKETOPLA(E2:E26;B2:B26;"Erzurum")

Bir adım daha ileri giderek formülü bir daha karmaşık hale getirelim. Karadeniz bölgesinde bulunan Emin Market' in Sebze satışlarının toplamını bulmak istiyorsak da formülü aşağıdaki şekilde kullanacağız;

=ÇOKETOPLA(E2:E26;A2:A26;"Karadeniz";C2:C26;"Emin Market";D2:D26;"Sebze")

Anlaşılacağı gibi A2:A26 ile ilk parametrenin aranacağı sütunu ve peşinden anahtar kelimeyi, C2:C26 ile ikinci arama sütununu ve peşinden o alanda aranacak anahtar kelimeyi ve D2:D26 ile de üçüncü parametreyi belirtmiş oluyoruz.

Yukarıdaki formüllerin sonuçları da şu şekilde görüntülenebilir;

Excel ÇOKETOPLA formülü - Formül Sonuçları

Bu örneklerden yola çıkarak daha karmaşık tablolarda istediğimiz kadar derinleştirebileceğimiz toplamlar bulmamız mümkün.
 



Bunlar da ilginizi çekebilir...

 



398 defa okunmuş. - 28.04.2021
Etiketler : excel,çoketopla formülü,Birden çok koşula dayalı olarak değerleri toplama,excel toplama işlemi,pivot
Serdar Kardan

Serdar Kardan

(25.08.1975) - Web Tasarım, Programlama

 
RSS

e-Posta Aboneliği

Delivered by FeedBurner

 

En çok Okunanlar
- EXCEL – Saat fark ve toplamı hesaplama ( 35334 )
- Gizli Sürücü ve Donanımları Kaldırmak ( 27655 )
- EXCEL – Merkez Bankası Döviz Kuru Görüntüleme ( 24937 )
- Unutulan SQL SA Şifresini Değiştirme ( 18443 )
- Windows 7 Geçici Profil Açma Sorunu ( 17394 )



Bumerang - Yazarkafe